Thursday, 29 December 2016

Trying to get a fan

Yesterday to try and keep out of the heat I stayed inside and tried to get some work done on the CNC Mill. I have tested all of the steppers and everything looks good there. However the Pololu stepper drivers I have only have a fairly small heatsink on them. I am not exceeding the rating that is recommended with the supplied heatsink, but I am at the limit of what can be done there. So with that in mind, I would like a bit more headroom.

When LMC built this control box they quite kindly left a fan shaped cutout for me. Unfortunately the fan that was originally in there ran from the 110V mains this was set up for. So I plan to use one of the PC fans that I have sitting around here instead.
This fan is close enough to a good fit in the cutout that it will work fine. However, upon testing I found that it would not spin. The cogging effect was increased though. Then I looked at the small print. It is a brushless DC motor. I do not know much about these, but it seems they need a varying DC waveform rather than pure DC.

So where in here can I get a varying DC waveform from? One of the PWM outputs from the BeBoPr Beaglebone cape of course. The plan was to get machinekit running and then set up a user controlled variable to adjust the PWM duty cycle until I found the sweet spot. Then set it u so that whenever the machine is turned on in Machinekit then the fan would start.

That was a good plan. Except for the fact that because I haven't done anything with this for months and months. I couldn't get machinekit to run at all. Then I tried a new, clean image to make sure that there wasn't a setting causing the problem. However then I ran into a problem with my HDMI to VGA adapter. Apparently the Beaglebone Black doesn't supply enough current over the HDMI port to run a passive adapter. So I either have to hook this up to the TV in the loungeroom, buy an active adapter or I can mod the passive adapter. I actually have all the parts I need to be able to regulate the 12V down to 5V needed and wire up the regulator. So I might end up doing that.

So keep an eye out for either a fan installation, or modding a passive HDMI to VGA adapter.

Cheers,
Rex



Actually I just remembered that I have a fan in one of my servers that is run from a molex connector for the disk drives. That means it runs from 5 or 12V DC and can be made to work here. Seeing as I am not using the servers anymore I might just re-purpose it for this.