Sunday, 29 November 2015

The Mill moves again

On the weekend I had the opportunity to play with the CNC mill again.
We last left it running, with the power supply integrated into the case. The old computer power supply had enough juice to run the beaglebone, but unfortunately not enough grunt to energize the stepper motors. As soon as I tried to power them up some kind of overload protection would shut the whole thing down.

To help pinpoint the exact problem here I connected my benchtop powersupply in parallel with the computer supply over the stepper driver input. This worked and I could switch machine power on and off without issue. To see if the problem was just an initial surge overloading the PSU I unplugged the benchtop supply to see if everything would still run. It did; but the PSU started to make a funny sound and I'm sure I could smell something wrong. I plugged the benchtop supply back in and the noise went away immediately, with the smell disappearing shortly after.

So it looks like I don't have a big enough power supply. The solution? I've ordered a 240V to 12V 20A swichmode supply from eBay. At the price I decided to get the 20A model as it might be a little marginal at the rated power. By getting well over I should have plenty in reserve, particularly if I want to run the spindle off it as well.

Hopefully this will arrive by the end of the week and I'll be able to install it either next weekend, or the weekend after.

Busy times at the moment, I've got something else on order from eBay that should arrive early this week. That will be an interesting little project. And I picked up something interesting from the market today which I'll do a little post on as well. So keep an eye out for those coming up.

Cheers,
Rex